Looking for a solution to get pnp to work with trunking ports. The config is a upstream router (1941) with a EHWIC-D-8ESG-P and a downstream switch WS-C2960XR-48TS-I.
configured the router as follows:
ip dhcp pool PNP
network 10.243.208.192 255.255.255.192
default-router 10.243.208.193
option 43 ascii "5A1D;B2;K4;I10.0.180.10;J80
option 60 ascii 'ciscopnp'
remember
vlan 990
name TEST
interface vlan 990
ip address 10.243.208.193 255.255.255.192
pnp startup-vlan 990
interface GigabitEthernet 0/1/6 (a port of the 8 port module)
switchport trunk native vlan 999
switchport mode trunk
no ip address
sh cdp tlv app
APP TLV (Gig 0/1/6), Configured tlv type: 4099 value: 1
configured Gi0/1/6 as a accessport in vlan 990. The setup works just fine. Need the interface to be a trunk because after the config is pushed to the switch the port on the switch is a trunk port with native vlan 999.
Try int g1/0/6 as access port, does vlan 990 get configured on the 2960. What version of code is the 2960 running.
The switch stays in vlan 1, receives a ip address + dhcp options and goes from there...
2960 SW Version: 15.2.(2)E6
1941 Version: 15.6(3)M
It looks like the pnp startup-vlan is not being propagated via the switch in the 1941. You should see another TLV with the value of the startup vlan.
Try the following commands..
"
no pnp startup-vlan 990
pnp startup-vlan 990
"
then
sh cdp tlv app
executed the commands an now the vlan gets created at the 2960
sh cdp tlv app
APP TLV (Gig 0/1/6), Configured tlv type: 4099 value: 1
APP TLV (Gig 0/1/6), Configured tlv type: 4103 value: 990
Now the vlan exist on the 2960 but he can't get a ip address.
Config SW:
interface GigabitEthernet 1/0/48 (uplink to the router)
switchport access vlan 990
macro description CISCO_SMI_EVENT
interface Vlan990
ip address dhcp
Trunk port router (G0/1/6) has native vlan 999 and the port on the SW is configured as a access port with vlan 990.
When tried to change the native vlan to 990 getting the switch spanning-tree:
Received 802.1Q BPDU on non trunk GigabitEthernet 1/0/48 VLAN990.
Blocking GigabitEthernet 1/0/48 on vlan 990. Inconsistent port type.
you want to make trunking desirable on the uplink. Leave the native VLAN.
"switchport mode dynamic desirable"
Refer PnP blog series Network Automation with Plug and Play (PnP) – Part 4
and Network Automation with Plug and Play (PnP) – Part 5
That is not a option... Command doesn't exist on the 1941 with EHWIC-D-8ESG-P:
ROUTER1941(config)#int G0/1/6
ROUTER1941(config-if)#switchport mode ?
access Set trunking mode to ACCESS unconditionally
dot1q-tunnel Set trunking mode to TUNNEL unconditionally
trunk Set trunking mode to TRUNK unconditionally
Can you do "show int G0/1/6 switchport" too on 1941 and show us the output. It looks like switch module does not do dynamic trunking protocol (DTP).
If DTP is off, your switch will be in access mode. Then STP could be the factor here to block VLAN 999 due to type mistmatch (access one side, trunk on the other side).
Here is the output requested:
interface GigabitEthernet 0/1/6
switchport trunk native vlan 999
switchport mode trunk
no ip address
ROUTER1941#show int G0/1/6 switchport
Name:Gi0/1/6
Administrative mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode Vlan: 0 ((Inactive))
Trunking Native mode VLAN: 999 (Trunk)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,3,21,29,33,900,920,990,999
Protected: False
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice Vlan: none
Unable to set the Gi0/1/6 port in dynamic.
Right now, our smart install macro in switch does not handle the scenario when DTP is off. It relies on DTP to decide what is mode the port should be and macro will kick off the configuration as access or trunk accordingly. We need to enhance the capability to handle DTP off scenario like this.
NIM module on ISR4K supports DTP, so you will not have issues there. For the switch module on ISRG2, try to upgrade it to latest release, which may support DTP .
Unfortunately, today the macro is hidden from users. We should add the intelligence in the future when DTP is off, if we see multiple do1q BPDUs, we should know it is statically set to trunk on uplink. Then we should set the new switch port as trunk and problem will be resolved. That is matter of how to implement and when.
Comments
0 comments
Please sign in to leave a comment.